• contact@rep-secretariat.fr

Détecter des doublons sur Excel

par Elodie REP

10 03 2015 | Catégorie : Excel et Compagnie | 0 Commentaires

Après des heures de saisie et de copier-coller, personne n’est à l’abri d’une erreur et des doublons se sont souvent cachés (oui oui ils sont sournois !) dans votre tableau.

Voici deux méthodes différentes pour les trouver rapidement et sans prise de tête.

A/ La méthode radicale : suppression directe et définitive des doublons par Excel

  • Sélectionnez votre tableau (Ctrl+*),
  • Dans l’onglet Données, cliquez sur « Supprimer les doublons »,

Excel propose une option automatique pour supprimer vos doublons

 

  • Choisissez les colonnes concernées, si votre tableau a des en-têtes et validez :

comment trouver vos doublons sur excel ?

  • Excel supprime automatiquement toutes les lignes qu’il considère en double :

trouver et supprimer vos doublons

  • Si Excel ne trouve pas de doublons dans votre tableau, vous verrez alors ce message :

pas de doublons sur excel

Et voilà vos doublons sont supprimés !

B/ La méthode sécurité : détection simple de vos doublons, à vous après de les modifier ou les supprimer

  • Créez une colonne supplémentaire (Z dans mon exemple),
  • Saisissez cette formule dans la nouvelle colonne : =SI(NB.SI($A$1:Z100;A1)>1; »Doublon »; » « )
    (dans cet exemple, je recherche des doublons par rapport à ma colonne A, modifiez la lettre si vous voulez faire la recherche pour une autre colonne)

formule sur Excel pour les doublons

  • Recopiez cette formule vers le bas jusqu’à la fin de votre tableau (en cliquant sur le point noir en bas à droite de la cellule et glissez jusqu’en bas),
  • A vous de jouer ensuite : une correction d’un des doublons (lié à une faute de frappe), une vérification ou une suppression,
  • Vous pouvez utiliser un filtre pour regrouper ces doublons (sélectionnez la première ligne et faites filtrer dans l’onglet données, puis sélectionnez uniquement « doublons »)

detecter des doublons Excel

 

Laisser un commentaire



Répondre

Votre adresse mail ne sera pas publiée.

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

REP Secrétariat

  • Elodie Barrillié
  • contact@rep-secretariat.fr

Rendez-vous sur la boutique

La boutique de REP Secretariat

Retrouvez sur la boutique de nombreux fichiers Excel à télécharger : modèles de factures, tableaux de suivi, plannings...Pour votre entreprise ou pour vous au quotidien.